CRAN Package Check Results for Package smoothSurv

Last updated on 2016-07-29 11:49:53.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.6 25.07 43.11 68.18 WARN
r-devel-linux-x86_64-debian-gcc 1.6 26.36 40.77 67.13 OK
r-devel-linux-x86_64-fedora-clang 1.6 137.48 OK
r-devel-linux-x86_64-fedora-gcc 1.6 123.94 OK
r-devel-osx-x86_64-clang 1.6 92.26 OK
r-devel-windows-ix86+x86_64 1.6 81.00 89.00 170.00 OK
r-patched-linux-x86_64 1.6 21.32 46.16 67.48 OK
r-patched-solaris-sparc 1.6 696.80 OK
r-patched-solaris-x86 1.6 135.80 OK
r-release-linux-x86_64 1.6 22.01 49.01 71.01 OK
r-release-osx-x86_64-mavericks 1.6 OK
r-release-windows-ix86+x86_64 1.6 79.00 107.00 186.00 OK
r-oldrel-windows-ix86+x86_64 1.6 73.00 139.00 212.00 OK

Check Details

Version: 1.6
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     ./Scythe_IDE.cpp:70:3: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:107:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:108:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:109:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:147:3: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:148:3: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:149:3: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:189:3: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:211:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:212:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:262:3: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:265:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
     ./Scythe_IDE.cpp:266:4: warning: 'register' storage class specifier is deprecated and incompatible with C++1z [-Wdeprecated-register]
Flavor: r-devel-linux-x86_64-debian-clang